bioPDF.PdfWriter Namespace

[image]

.NET Framework Class Library
bioPDF.PdfWriter Namespace

Classes

Class | Description
ComPdfSettings | This class can read and write setting files for the PDF Writer. You can use this to specify a large number of properties for the PDF Writer print jobs. If you are programming in .NET you should use the PdfSettings class instead of this one. From a COM client you instantiate this object using the prog id bioPDF.PdfSettings or class id DA427B24-0BD8-47e4-9756-865BF094AB39.
ComPdfUtil | COM interface for class PdfUtil.
PdfSettings | This class represents the settings of a PDF creation job.
PdfUtil | Helper class for creating PDF files.

Enumerations

Enumeration | Description
PdfSettingsFileType | Types of settings files.
PdfUtil..::.EncryptionType | Encryption types when creating password protected PDF documents.
PdfUtil..::.PrinterSelection | How to selelct a printer.


ComPdfSettings Class

[image]

.NET Framework Class Library
ComPdfSettings Class
Members See Also

This class can read and write setting files for the PDF Writer. You can use this to specify a large number of properties for the PDF Writer print jobs. If you are programming in .NET you should use the PdfSettings class instead of this one.

From a COM client you instantiate this object using the prog id bioPDF.PdfSettings or class id DA427B24-0BD8-47e4-9756-865BF094AB39.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Class ComPdfSettings
C#
public class ComPdfSettings
Visual C++
public ref class ComPdfSettings
JavaScript
bioPDF.PdfWriter.ComPdfSettings = function();

Type.createClass(
    'bioPDF.PdfWriter.ComPdfSettings');

Inheritance Hierarchy

System..::.Object
bioPDF.PdfWriter..::.ComPdfSettings

See Also

ComPdfSettings Members
bioPDF.PdfWriter Namespace


ComPdfSettings Members

[image] [image]

.NET Framework Class Library
ComPdfSettings Members
ComPdfSettings Class Constructors Methods Properties See Also

The ComPdfSettings type exposes the following members.

Constructors

Name | Description
ComPdfSettings |

Methods

Name | Description
GetSettingsFilePath | COM wrapper for GetSettingsFilePath(Boolean).
GetSettingsFilePathEx | COM wrapper for GetSettingsFilePath(PdfSettingsFileType).
GetSettingsFilePathEx2 | COM wrapper for GetSettingsFilePath(PdfSettingsFileType, String).
GetValue | COM wrapper for GetValue(String).
Init | COM wrapper for Init()()().
LoadSettings | COM wrapper for LoadSettings(Boolean).
LoadSettingsFile | COM wrapper for LoadSettings(String).
RemoveSettings | COM wrapper for RemoveSettings(Boolean).
RemoveSettingsFile | COM wrapper for RemoveSettings(String).
SetValue | COM wrapper for SetValue(String, String).
WriteSettings | COM wrapper for WriteSettings(Boolean).
WriteSettingsFile | COM wrapper for WriteSettings(String).

Properties

Name | Description
PrinterName | COM wrapper for PrinterName.
PrinterVersion | COM wrapper for PrinterVersion.
Version | COM wrapper for Version.

See Also

ComPdfSettings Class


ComPdfSettings Constructor

[image]

.NET Framework Class Library
ComPdfSettings Constructor
ComPdfSettings Class See Also

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComPdfSettings()
Visual C++
public:
ComPdfSettings()
JavaScript
bioPDF.PdfWriter.ComPdfSettings = function();

See Also

ComPdfSettings Class


ComPdfSettings Methods

[image] [image]

.NET Framework Class Library
ComPdfSettings Methods
ComPdfSettings Class See Also

The ComPdfSettings type exposes the following members.

Methods

Name | Description
GetSettingsFilePath | COM wrapper for GetSettingsFilePath(Boolean).
GetSettingsFilePathEx | COM wrapper for GetSettingsFilePath(PdfSettingsFileType).
GetSettingsFilePathEx2 | COM wrapper for GetSettingsFilePath(PdfSettingsFileType, String).
GetValue | COM wrapper for GetValue(String).
Init | COM wrapper for Init()()().
LoadSettings | COM wrapper for LoadSettings(Boolean).
LoadSettingsFile | COM wrapper for LoadSettings(String).
RemoveSettings | COM wrapper for RemoveSettings(Boolean).
RemoveSettingsFile | COM wrapper for RemoveSettings(String).
SetValue | COM wrapper for SetValue(String, String).
WriteSettings | COM wrapper for WriteSettings(Boolean).
WriteSettingsFile | COM wrapper for WriteSettings(String).

See Also

ComPdfSettings Class


GetSettingsFilePath Method

[image]

.NET Framework Class Library
ComPdfSettings..::.GetSettingsFilePath Method
ComPdfSettings Class See Also

COM wrapper for GetSettingsFilePath(Boolean).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSettingsFilePath ( _
    isRunOnce As Boolean _
) As String
C#
public string GetSettingsFilePath(
    bool isRunOnce
)
Visual C++
public:
virtual String^ GetSettingsFilePath(
    bool isRunOnce
) sealed
JavaScript
function getSettingsFilePath(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean

See Also

ComPdfSettings Class


GetSettingsFilePathEx Method

[image]

.NET Framework Class Library
ComPdfSettings..::.GetSettingsFilePathEx Method
ComPdfSettings Class See Also

COM wrapper for GetSettingsFilePath(PdfSettingsFileType).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSettingsFilePathEx ( _
    settingsFileType As String _
) As String
C#
public string GetSettingsFilePathEx(
    string settingsFileType
)
Visual C++
public:
virtual String^ GetSettingsFilePathEx(
    String^ settingsFileType
) sealed
JavaScript
function getSettingsFilePathEx(settingsFileType);

Parameters

settingsFileType
Type: System..::.String

See Also

ComPdfSettings Class


GetSettingsFilePathEx2 Method

[image]

.NET Framework Class Library
ComPdfSettings..::.GetSettingsFilePathEx2 Method
ComPdfSettings Class See Also

COM wrapper for GetSettingsFilePath(PdfSettingsFileType, String).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSettingsFilePathEx2 ( _
    settingsFileType As String, _
    documentName As String _
) As String
C#
public string GetSettingsFilePathEx2(
    string settingsFileType,
    string documentName
)
Visual C++
public:
virtual String^ GetSettingsFilePathEx2(
    String^ settingsFileType,
    String^ documentName
) sealed
JavaScript
function getSettingsFilePathEx2(settingsFileType, documentName);

Parameters

settingsFileType
Type: System..::.String
documentName
Type: System..::.String

Return Value

See Also

ComPdfSettings Class


GetValue Method

[image]

.NET Framework Class Library
ComPdfSettings..::.GetValue Method
ComPdfSettings Class See Also

COM wrapper for GetValue(String).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue ( _
    configName As String _
) As String
C#
public string GetValue(
    string configName
)
Visual C++
public:
virtual String^ GetValue(
    String^ configName
) sealed
JavaScript
function getValue(configName);

Parameters

configName
Type: System..::.String

See Also

ComPdfSettings Class


Init Method

[image]

.NET Framework Class Library
ComPdfSettings..::.Init Method
ComPdfSettings Class See Also

COM wrapper for Init()()().

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub Init
C#
public void Init()
Visual C++
public:
virtual void Init() sealed
JavaScript
function init();

See Also

ComPdfSettings Class


LoadSettings Method

[image]

.NET Framework Class Library
ComPdfSettings..::.LoadSettings Method
ComPdfSettings Class See Also

COM wrapper for LoadSettings(Boolean).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadSettings ( _
    isRunOnce As Boolean _
)
C#
public void LoadSettings(
    bool isRunOnce
)
Visual C++
public:
virtual void LoadSettings(
    bool isRunOnce
) sealed
JavaScript
function loadSettings(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean

See Also

ComPdfSettings Class


LoadSettingsFile Method

[image]

.NET Framework Class Library
ComPdfSettings..::.LoadSettingsFile Method
ComPdfSettings Class See Also

COM wrapper for LoadSettings(String).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadSettingsFile ( _
    fileName As String _
)
C#
public void LoadSettingsFile(
    string fileName
)
Visual C++
public:
virtual void LoadSettingsFile(
    String^ fileName
) sealed
JavaScript
function loadSettingsFile(fileName);

Parameters

fileName
Type: System..::.String

See Also

ComPdfSettings Class


RemoveSettings Method

[image]

.NET Framework Class Library
ComPdfSettings..::.RemoveSettings Method
ComPdfSettings Class See Also

COM wrapper for RemoveSettings(Boolean).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveSettings ( _
    isRunOnce As Boolean _
)
C#
public void RemoveSettings(
    bool isRunOnce
)
Visual C++
public:
virtual void RemoveSettings(
    bool isRunOnce
) sealed
JavaScript
function removeSettings(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean

See Also

ComPdfSettings Class


RemoveSettingsFile Method

[image]

.NET Framework Class Library
ComPdfSettings..::.RemoveSettingsFile Method
ComPdfSettings Class See Also

COM wrapper for RemoveSettings(String).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveSettingsFile ( _
    fileName As String _
)
C#
public void RemoveSettingsFile(
    string fileName
)
Visual C++
public:
virtual void RemoveSettingsFile(
    String^ fileName
) sealed
JavaScript
function removeSettingsFile(fileName);

Parameters

fileName
Type: System..::.String

See Also

ComPdfSettings Class


SetValue Method

[image]

.NET Framework Class Library
ComPdfSettings..::.SetValue Method
ComPdfSettings Class See Also

COM wrapper for SetValue(String, String).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetValue ( _
    configName As String, _
    configValue As String _
)
C#
public void SetValue(
    string configName,
    string configValue
)
Visual C++
public:
virtual void SetValue(
    String^ configName,
    String^ configValue
) sealed
JavaScript
function setValue(configName, configValue);

Parameters

configName
Type: System..::.String
configValue
Type: System..::.String

See Also

ComPdfSettings Class


WriteSettings Method

[image]

.NET Framework Class Library
ComPdfSettings..::.WriteSettings Method
ComPdfSettings Class See Also

COM wrapper for WriteSettings(Boolean).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteSettings ( _
    isRunOnce As Boolean _
)
C#
public void WriteSettings(
    bool isRunOnce
)
Visual C++
public:
virtual void WriteSettings(
    bool isRunOnce
) sealed
JavaScript
function writeSettings(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean

See Also

ComPdfSettings Class


WriteSettingsFile Method

[image]

.NET Framework Class Library
ComPdfSettings..::.WriteSettingsFile Method
ComPdfSettings Class See Also

COM wrapper for WriteSettings(String).

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteSettingsFile ( _
    fileName As String _
)
C#
public void WriteSettingsFile(
    string fileName
)
Visual C++
public:
virtual void WriteSettingsFile(
    String^ fileName
) sealed
JavaScript
function writeSettingsFile(fileName);

Parameters

fileName
Type: System..::.String

See Also

ComPdfSettings Class


ComPdfSettings Properties

[image] [image]

.NET Framework Class Library
ComPdfSettings Properties
ComPdfSettings Class See Also

The ComPdfSettings type exposes the following members.

Properties

Name | Description
PrinterName | COM wrapper for PrinterName.
PrinterVersion | COM wrapper for PrinterVersion.
Version | COM wrapper for Version.

See Also

ComPdfSettings Class


PrinterName Property

[image]

.NET Framework Class Library
ComPdfSettings..::.PrinterName Property
ComPdfSettings Class See Also

COM wrapper for PrinterName.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Property PrinterName As String
C#
public string PrinterName { get; set; }
Visual C++
public:
virtual property String^ PrinterName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_printerName();
function set_printerName(value);

See Also

ComPdfSettings Class


PrinterVersion Property

[image]

.NET Framework Class Library
ComPdfSettings..::.PrinterVersion Property
ComPdfSettings Class See Also

COM wrapper for PrinterVersion.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrinterVersion As String
C#
public string PrinterVersion { get; }
Visual C++
public:
virtual property String^ PrinterVersion {
    String^ get () sealed;
}
JavaScript
function get_printerVersion();

See Also

ComPdfSettings Class


Version Property

[image]

.NET Framework Class Library
ComPdfSettings..::.Version Property
ComPdfSettings Class See Also

COM wrapper for Version.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As String
C#
public string Version { get; }
Visual C++
public:
virtual property String^ Version {
    String^ get () sealed;
}
JavaScript
function get_version();

See Also

ComPdfSettings Class


ComPdfUtil Class

[image]

.NET Framework Class Library
ComPdfUtil Class
Members See Also

COM interface for class PdfUtil.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Class ComPdfUtil
C#
public class ComPdfUtil
Visual C++
public ref class ComPdfUtil
JavaScript
bioPDF.PdfWriter.ComPdfUtil = function();

Type.createClass(
    'bioPDF.PdfWriter.ComPdfUtil');

Remarks

The class is accessible to COM clients through the prog id "bioPDF.PdfUtil".

Inheritance Hierarchy

System..::.Object
bioPDF.PdfWriter..::.ComPdfUtil

See Also

ComPdfUtil Members


ComPdfUtil Members

[image] [image]

.NET Framework Class Library
ComPdfUtil Members
ComPdfUtil Class Constructors Methods Properties See Also

The ComPdfUtil type exposes the following members.

Constructors

Name | Description
ComPdfUtil |

Methods

Name | Description
DecryptSetting | Decrypt string encrypted using the Encrypt method.
EncryptPdf | Encrypt a PDF document.
EncryptSetting | Encrypt string for two way encryption.
GetCompatiblePrinters | Get list of compatible printers
GetPrinterAppFolder | COM Wrapper for static method PdfUtil.GetPrinterAppFolder.
GetPrinterVersion | COM Wrapper for static method PdfUtil.GetPrinterVersion.
Merge | Merge two or more PDF files. This function requires that you have pdftk.exe installed in your PDF writer application folder.
PrintFile | COM Wrapper for static method PdfUtil.PrintFile.
PrintPdf | Send an existing PDF file to a printer
ReadIniString | Read a string from an ini file.
SignPdf | Apply a digital signature to a PDF document.
SignPdfByThumbprint | Apply a digital signature to a PDF document.
SignPdfByThumbprintEx | Apply a digital signature to a PDF document.
SignPdfEx | Apply a digital signature to a PDF document.
WaitForFile | COM Wrapper for static method PdfUtil.WaitForFile.
WriteIniString | Write a string to an ini file.

Properties

Name | Description
DefaultPrinterName | Returns the default printer name for the assembly.

See Also

ComPdfUtil Class


ComPdfUtil Constructor

[image]

.NET Framework Class Library
ComPdfUtil Constructor
ComPdfUtil Class See Also

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComPdfUtil()
Visual C++
public:
ComPdfUtil()
JavaScript
bioPDF.PdfWriter.ComPdfUtil = function();

See Also

ComPdfUtil Class


ComPdfUtil Methods

[image] [image]

.NET Framework Class Library
ComPdfUtil Methods
ComPdfUtil Class See Also

The ComPdfUtil type exposes the following members.

Methods

Name | Description
DecryptSetting | Decrypt string encrypted using the Encrypt method.
EncryptPdf | Encrypt a PDF document.
EncryptSetting | Encrypt string for two way encryption.
GetCompatiblePrinters | Get list of compatible printers
GetPrinterAppFolder | COM Wrapper for static method PdfUtil.GetPrinterAppFolder.
GetPrinterVersion | COM Wrapper for static method PdfUtil.GetPrinterVersion.
Merge | Merge two or more PDF files. This function requires that you have pdftk.exe installed in your PDF writer application folder.
PrintFile | COM Wrapper for static method PdfUtil.PrintFile.
PrintPdf | Send an existing PDF file to a printer
ReadIniString | Read a string from an ini file.
SignPdf | Apply a digital signature to a PDF document.
SignPdfByThumbprint | Apply a digital signature to a PDF document.
SignPdfByThumbprintEx | Apply a digital signature to a PDF document.
SignPdfEx | Apply a digital signature to a PDF document.
WaitForFile | COM Wrapper for static method PdfUtil.WaitForFile.
WriteIniString | Write a string to an ini file.

See Also

ComPdfUtil Class


DecryptSetting Method

[image]

.NET Framework Class Library
ComPdfUtil..::.DecryptSetting Method
ComPdfUtil Class See Also

Decrypt string encrypted using the Encrypt method.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function DecryptSetting ( _
    input As String _
) As String
C#
public string DecryptSetting(
    string input
)
Visual C++
public:
virtual String^ DecryptSetting(
    String^ input
) sealed
JavaScript
function decryptSetting(input);

Parameters

input
Type: System..::.String
Encrypted string

Return Value

Decrypted Unicode string.

See Also

ComPdfUtil Class


EncryptPdf Method

[image]

.NET Framework Class Library
ComPdfUtil..::.EncryptPdf Method
ComPdfUtil Class See Also

Encrypt a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub EncryptPdf ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    ownerPassword As String, _
    userPassword As String, _
    encryptionType As String, _
    allowAssembly As Boolean, _
    allowCopy As Boolean, _
    allowDegradedPrinting As Boolean, _
    allowFillIn As Boolean, _
    allowModifyAnnotations As Boolean, _
    allowModifyContents As Boolean, _
    allowPrinting As Boolean, _
    allowScreenReaders As Boolean _
)
C#
public void EncryptPdf(
    string printerName,
    string inputFileName,
    string outputFileName,
    string ownerPassword,
    string userPassword,
    string encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
Visual C++
public:
virtual void EncryptPdf(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ ownerPassword,
    String^ userPassword,
    String^ encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
) sealed
JavaScript
function encryptPdf(printerName, inputFileName, outputFileName, ownerPassword, userPassword, encryptionType, allowAssembly, allowCopy, allowDegradedPrinting, allowFillIn, allowModifyAnnotations, allowModifyContents, allowPrinting, allowScreenReaders);

Parameters

printerName
Type: System..::.String
inputFileName
Type: System..::.String
outputFileName
Type: System..::.String
ownerPassword
Type: System..::.String
userPassword
Type: System..::.String
encryptionType
Type: System..::.String
allowAssembly
Type: System..::.Boolean
allowCopy
Type: System..::.Boolean
allowDegradedPrinting
Type: System..::.Boolean
allowFillIn
Type: System..::.Boolean
allowModifyAnnotations
Type: System..::.Boolean
allowModifyContents
Type: System..::.Boolean
allowPrinting
Type: System..::.Boolean
allowScreenReaders
Type: System..::.Boolean

See Also

ComPdfUtil Class


EncryptSetting Method

[image]

.NET Framework Class Library
ComPdfUtil..::.EncryptSetting Method
ComPdfUtil Class See Also

Encrypt string for two way encryption.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function EncryptSetting ( _
    input As String _
) As String
C#
public string EncryptSetting(
    string input
)
Visual C++
public:
virtual String^ EncryptSetting(
    String^ input
) sealed
JavaScript
function encryptSetting(input);

Parameters

input
Type: System..::.String
Unicode string to encrypt

Return Value

Encrypted data

See Also

ComPdfUtil Class


GetCompatiblePrinters Method

[image]

.NET Framework Class Library
ComPdfUtil..::.GetCompatiblePrinters Method
ComPdfUtil Class See Also

Get list of compatible printers

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCompatiblePrinters As Object()
C#
public Object[] GetCompatiblePrinters()
Visual C++
public:
virtual array<Object^>^ GetCompatiblePrinters() sealed
JavaScript
function getCompatiblePrinters();

Return Value

Array of compatible printers

See Also

ComPdfUtil Class


GetPrinterAppFolder Method

[image]

.NET Framework Class Library
ComPdfUtil..::.GetPrinterAppFolder Method
ComPdfUtil Class See Also

COM Wrapper for static method PdfUtil.GetPrinterAppFolder.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPrinterAppFolder ( _
    printerName As String _
) As String
C#
public string GetPrinterAppFolder(
    string printerName
)
Visual C++
public:
virtual String^ GetPrinterAppFolder(
    String^ printerName
) sealed
JavaScript
function getPrinterAppFolder(printerName);

Parameters

printerName
Type: System..::.String

See Also

ComPdfUtil Class


GetPrinterVersion Method

[image]

.NET Framework Class Library
ComPdfUtil..::.GetPrinterVersion Method
ComPdfUtil Class See Also

COM Wrapper for static method PdfUtil.GetPrinterVersion.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPrinterVersion ( _
    printerName As String _
) As String
C#
public string GetPrinterVersion(
    string printerName
)
Visual C++
public:
virtual String^ GetPrinterVersion(
    String^ printerName
) sealed
JavaScript
function getPrinterVersion(printerName);

Parameters

printerName
Type: System..::.String

See Also

ComPdfUtil Class


Merge Method

[image]

.NET Framework Class Library
ComPdfUtil..::.Merge Method
ComPdfUtil Class See Also

Merge two or more PDF files. This function requires that you have pdftk.exe installed in your PDF writer application folder.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub Merge ( _
    inputFileNames As String(), _
    outputFileName As String, _
    printerName As String, _
    timeoutMilliseconds As Integer _
)
C#
public void Merge(
    string[] inputFileNames,
    string outputFileName,
    string printerName,
    int timeoutMilliseconds
)
Visual C++
public:
virtual void Merge(
    array<String^>^ inputFileNames,
    String^ outputFileName,
    String^ printerName,
    int timeoutMilliseconds
) sealed
JavaScript
function merge(inputFileNames, outputFileName, printerName, timeoutMilliseconds);

Parameters

inputFileNames
Type: array< System..::.String >[]()[]
Array of files to merge.
outputFileName
Type: System..::.String
Path of output file.
printerName
Type: System..::.String
Name of PDF printer.
timeoutMilliseconds
Type: System..::.Int32
Timeout in milliseconds for external processes launched during the merge operation.

See Also

ComPdfUtil Class


PrintFile Method

[image]

.NET Framework Class Library
ComPdfUtil..::.PrintFile Method
ComPdfUtil Class See Also

COM Wrapper for static method PdfUtil.PrintFile.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function PrintFile ( _
    fileName As String, _
    printerName As String _
) As Boolean
C#
public bool PrintFile(
    string fileName,
    string printerName
)
Visual C++
public:
virtual bool PrintFile(
    String^ fileName,
    String^ printerName
) sealed
JavaScript
function printFile(fileName, printerName);

Parameters

fileName
Type: System..::.String
printerName
Type: System..::.String

See Also

ComPdfUtil Class


PrintPdf Method

[image]

.NET Framework Class Library
ComPdfUtil..::.PrintPdf Method
ComPdfUtil Class See Also

Send an existing PDF file to a printer

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub PrintPdf ( _
    pdfFileName As String, _
    printerSelection As String, _
    printToPrinterName As String, _
    pdfPrinterName As String, _
    showProgress As Boolean, _
    bitsPerPixel As Integer, _
    documentName As String, _
    maxResolution As Integer, _
    scaleToFit As Boolean, _
    firstPage As Integer, _
    lastPage As Integer, _
    timeoutMilliseconds As Integer _
)
C#
public void PrintPdf(
    string pdfFileName,
    string printerSelection,
    string printToPrinterName,
    string pdfPrinterName,
    bool showProgress,
    int bitsPerPixel,
    string documentName,
    int maxResolution,
    bool scaleToFit,
    int firstPage,
    int lastPage,
    int timeoutMilliseconds
)
Visual C++
public:
virtual void PrintPdf(
    String^ pdfFileName,
    String^ printerSelection,
    String^ printToPrinterName,
    String^ pdfPrinterName,
    bool showProgress,
    int bitsPerPixel,
    String^ documentName,
    int maxResolution,
    bool scaleToFit,
    int firstPage,
    int lastPage,
    int timeoutMilliseconds
) sealed
JavaScript
function printPdf(pdfFileName, printerSelection, printToPrinterName, pdfPrinterName, showProgress, bitsPerPixel, documentName, maxResolution, scaleToFit, firstPage, lastPage, timeoutMilliseconds);

Parameters

pdfFileName
Type: System..::.String
Full path to PDF file to print.
printerSelection
Type: System..::.String
How the printer will be selected. Valid values are "usedefault", "ask", "specific".
printToPrinterName
Type: System..::.String
Name of printer to print to if a specific printer is used.
pdfPrinterName
Type: System..::.String
Name of PDF printer that this API is linked to.
showProgress
Type: System..::.Boolean
Show render progress.
bitsPerPixel
Type: System..::.Int32
Valid values are 1, 4, 8, 24.
documentName
Type: System..::.String
Name of document in spooler queue.
maxResolution
Type: System..::.Int32
Maximum DPI resolution for print job.
scaleToFit
Type: System..::.Boolean
Scale the content to fit the paper.
firstPage
Type: System..::.Int32
Page number of first page to print.
lastPage
Type: System..::.Int32
Page number of last page to print. 0 is default and will print all pages after the first selected page.
timeoutMilliseconds
Type: System..::.Int32
Maximum time to wait for print job to render.

See Also

ComPdfUtil Class


ReadIniString Method

[image]

.NET Framework Class Library
ComPdfUtil..::.ReadIniString Method
ComPdfUtil Class See Also

Read a string from an ini file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadIniString ( _
    fileName As String, _
    sectionName As String, _
    valueName As String, _
    defaultValue As String _
) As String
C#
public string ReadIniString(
    string fileName,
    string sectionName,
    string valueName,
    string defaultValue
)
Visual C++
public:
virtual String^ ReadIniString(
    String^ fileName,
    String^ sectionName,
    String^ valueName,
    String^ defaultValue
) sealed
JavaScript
function readIniString(fileName, sectionName, valueName, defaultValue);

Parameters

fileName
Type: System..::.String
File name of ini file.
sectionName
Type: System..::.String
Name of section in ini file.
valueName
Type: System..::.String
Name of value in section.
defaultValue
Type: System..::.String
Default value to return if value was not found.

Return Value

See Also

ComPdfUtil Class


SignPdf Method

[image]

.NET Framework Class Library
ComPdfUtil..::.SignPdf Method
ComPdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub SignPdf ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateFileName As String, _
    certificatePassword As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer _
)
C#
public void SignPdf(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateFileName,
    string certificatePassword,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
)
Visual C++
public:
virtual void SignPdf(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateFileName,
    String^ certificatePassword,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
) sealed
JavaScript
function signPdf(printerName, inputFileName, outputFileName, certificateFileName, certificatePassword, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateFileName
Type: System..::.String
File name of the PFX certificate file
certificatePassword
Type: System..::.String
Certificate private key password
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.

See Also

ComPdfUtil Class


SignPdfByThumbprint Method

[image]

.NET Framework Class Library
ComPdfUtil..::.SignPdfByThumbprint Method
ComPdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub SignPdfByThumbprint ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateThumbprint As String, _
    certificateStoreName As String, _
    certificateStoreLocation As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer _
)
C#
public void SignPdfByThumbprint(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateThumbprint,
    string certificateStoreName,
    string certificateStoreLocation,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
)
Visual C++
public:
virtual void SignPdfByThumbprint(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateThumbprint,
    String^ certificateStoreName,
    String^ certificateStoreLocation,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
) sealed
JavaScript
function signPdfByThumbprint(printerName, inputFileName, outputFileName, certificateThumbprint, certificateStoreName, certificateStoreLocation, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateThumbprint
Type: System..::.String
Thumbprint string of certificate in the certificate store.
certificateStoreName
Type: System..::.String
Name of the certificate store (AddressBook, AuthRoot, CertificateAuthority, Disallowed, My (default), Root, TrustedPeople, TrustedPublisher)
certificateStoreLocation
Type: System..::.String
Location of the certificate store (CurrentUser (default), LocalMachine).
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.

See Also

ComPdfUtil Class


SignPdfByThumbprintEx Method

[image]

.NET Framework Class Library
ComPdfUtil..::.SignPdfByThumbprintEx Method
ComPdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub SignPdfByThumbprintEx ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateThumbprint As String, _
    certificateStoreName As String, _
    certificateStoreLocation As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer, _
    ownerPassword As String, _
    userPassword As String, _
    encryptionType As String, _
    allowAssembly As Boolean, _
    allowCopy As Boolean, _
    allowDegradedPrinting As Boolean, _
    allowFillIn As Boolean, _
    allowModifyAnnotations As Boolean, _
    allowModifyContents As Boolean, _
    allowPrinting As Boolean, _
    allowScreenReaders As Boolean _
)
C#
public void SignPdfByThumbprintEx(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateThumbprint,
    string certificateStoreName,
    string certificateStoreLocation,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    string ownerPassword,
    string userPassword,
    string encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
Visual C++
public:
virtual void SignPdfByThumbprintEx(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateThumbprint,
    String^ certificateStoreName,
    String^ certificateStoreLocation,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    String^ ownerPassword,
    String^ userPassword,
    String^ encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
) sealed
JavaScript
function signPdfByThumbprintEx(printerName, inputFileName, outputFileName, certificateThumbprint, certificateStoreName, certificateStoreLocation, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage, ownerPassword, userPassword, encryptionType, allowAssembly, allowCopy, allowDegradedPrinting, allowFillIn, allowModifyAnnotations, allowModifyContents, allowPrinting, allowScreenReaders);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateThumbprint
Type: System..::.String
Thumbprint string of certificate in the certificate store.
certificateStoreName
Type: System..::.String
Name of the certificate store (AddressBook, AuthRoot, CertificateAuthority, Disallowed, My (default), Root, TrustedPeople, TrustedPublisher)
certificateStoreLocation
Type: System..::.String
Location of the certificate store (CurrentUser (default), LocalMachine).
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.
ownerPassword
Type: System..::.String
Owner password for PDF encryption.
userPassword
Type: System..::.String
User password for PDF encryption.
encryptionType
Type: System..::.String
Type and streangth of encryption.
allowAssembly
Type: System..::.Boolean
Allow assembly.
allowCopy
Type: System..::.Boolean
Allow copy to clipboard.
allowDegradedPrinting
Type: System..::.Boolean
Allow degraded printing.
allowFillIn
Type: System..::.Boolean
Allow fill in.
allowModifyAnnotations
Type: System..::.Boolean
Allow modifying annotations.
allowModifyContents
Type: System..::.Boolean
Allow modifying contents.
allowPrinting
Type: System..::.Boolean
Allow printing.
allowScreenReaders
Type: System..::.Boolean
Allow screen readers.

See Also

ComPdfUtil Class


SignPdfEx Method

[image]

.NET Framework Class Library
ComPdfUtil..::.SignPdfEx Method
ComPdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub SignPdfEx ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateFileName As String, _
    certificatePassword As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer, _
    ownerPassword As String, _
    userPassword As String, _
    encryptionType As String, _
    allowAssembly As Boolean, _
    allowCopy As Boolean, _
    allowDegradedPrinting As Boolean, _
    allowFillIn As Boolean, _
    allowModifyAnnotations As Boolean, _
    allowModifyContents As Boolean, _
    allowPrinting As Boolean, _
    allowScreenReaders As Boolean _
)
C#
public void SignPdfEx(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateFileName,
    string certificatePassword,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    string ownerPassword,
    string userPassword,
    string encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
Visual C++
public:
virtual void SignPdfEx(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateFileName,
    String^ certificatePassword,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    String^ ownerPassword,
    String^ userPassword,
    String^ encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
) sealed
JavaScript
function signPdfEx(printerName, inputFileName, outputFileName, certificateFileName, certificatePassword, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage, ownerPassword, userPassword, encryptionType, allowAssembly, allowCopy, allowDegradedPrinting, allowFillIn, allowModifyAnnotations, allowModifyContents, allowPrinting, allowScreenReaders);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateFileName
Type: System..::.String
File name of the PFX certificate file
certificatePassword
Type: System..::.String
Certificate private key password
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.
ownerPassword
Type: System..::.String
Owner password for PDF encryption.
userPassword
Type: System..::.String
User password for PDF encryption.
encryptionType
Type: System..::.String
Type and streangth of encryption.
allowAssembly
Type: System..::.Boolean
Allow assembly.
allowCopy
Type: System..::.Boolean
Allow copy to clipboard.
allowDegradedPrinting
Type: System..::.Boolean
Allow degraded printing.
allowFillIn
Type: System..::.Boolean
Allow fill in.
allowModifyAnnotations
Type: System..::.Boolean
Allow modifying annotations.
allowModifyContents
Type: System..::.Boolean
Allow modifying contents.
allowPrinting
Type: System..::.Boolean
Allow printing.
allowScreenReaders
Type: System..::.Boolean
Allow screen readers.

See Also

ComPdfUtil Class


WaitForFile Method

[image]

.NET Framework Class Library
ComPdfUtil..::.WaitForFile Method
ComPdfUtil Class See Also

COM Wrapper for static method PdfUtil.WaitForFile.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function WaitForFile ( _
    path As String, _
    timeoutMilliseconds As Integer _
) As Boolean
C#
public bool WaitForFile(
    string path,
    int timeoutMilliseconds
)
Visual C++
public:
virtual bool WaitForFile(
    String^ path,
    int timeoutMilliseconds
) sealed
JavaScript
function waitForFile(path, timeoutMilliseconds);

Parameters

path
Type: System..::.String
timeoutMilliseconds
Type: System..::.Int32

See Also

ComPdfUtil Class


WriteIniString Method

[image]

.NET Framework Class Library
ComPdfUtil..::.WriteIniString Method
ComPdfUtil Class See Also

Write a string to an ini file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteIniString ( _
    fileName As String, _
    sectionName As String, _
    valueName As String, _
    value As String _
)
C#
public void WriteIniString(
    string fileName,
    string sectionName,
    string valueName,
    string value
)
Visual C++
public:
virtual void WriteIniString(
    String^ fileName,
    String^ sectionName,
    String^ valueName,
    String^ value
) sealed
JavaScript
function writeIniString(fileName, sectionName, valueName, value);

Parameters

fileName
Type: System..::.String
File name of ini file.
sectionName
Type: System..::.String
Name of section in ini file.
valueName
Type: System..::.String
Name of value in section.
value
Type: System..::.String
Value to write.

See Also

ComPdfUtil Class


ComPdfUtil Properties

[image] [image]

.NET Framework Class Library
ComPdfUtil Properties
ComPdfUtil Class See Also

The ComPdfUtil type exposes the following members.

Properties

Name | Description
DefaultPrinterName | Returns the default printer name for the assembly.

See Also

ComPdfUtil Class


DefaultPrinterName Property

[image]

.NET Framework Class Library
ComPdfUtil..::.DefaultPrinterName Property
ComPdfUtil Class See Also

Returns the default printer name for the assembly.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultPrinterName As String
C#
public string DefaultPrinterName { get; }
Visual C++
public:
virtual property String^ DefaultPrinterName {
    String^ get () sealed;
}
JavaScript
function get_defaultPrinterName();

See Also

ComPdfUtil Class


PdfSettings Class

[image]

.NET Framework Class Library
PdfSettings Class
Members See Also

This class represents the settings of a PDF creation job.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Class PdfSettings
C#
public class PdfSettings
Visual C++
public ref class PdfSettings
JavaScript
bioPDF.PdfWriter.PdfSettings = function();

Type.createClass(
    'bioPDF.PdfWriter.PdfSettings');

Inheritance Hierarchy

System..::.Object
bioPDF.PdfWriter..::.PdfSettings

See Also

PdfSettings Members


PdfSettings Members

[image] [image]

.NET Framework Class Library
PdfSettings Members
PdfSettings Class Constructors Methods Properties See Also

The PdfSettings type exposes the following members.

Constructors

Name | Description
PdfSettings | The constructor creates the object and initializes it's internal state.

Methods

Name | Description
GetSettingsFilePath | Overloaded.
GetValue | Get the current value of a particular setting.
Init | Initialize the class.
LoadSettings | Overloaded.
RemoveSettings | Overloaded.
SetValue | Set a value in the configuration.
WriteSettings | Overloaded.

Properties

Name | Description
PrinterName | Specify which printer name the current settnings applies to.
PrinterVersion | Returns the version of the installed printer. It looks at the version information of gui.exe in the printer's program folder.
Version | The version of the assembly. This is not the same as the version of the printer.

See Also

PdfSettings Class


PdfSettings Constructor

[image]

.NET Framework Class Library
PdfSettings Constructor
PdfSettings Class See Also

The constructor creates the object and initializes it's internal state.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdfSettings()
Visual C++
public:
PdfSettings()
JavaScript
bioPDF.PdfWriter.PdfSettings = function();

See Also

PdfSettings Class


PdfSettings Methods

[image] [image]

.NET Framework Class Library
PdfSettings Methods
PdfSettings Class See Also

The PdfSettings type exposes the following members.

Methods

Name | Description
GetSettingsFilePath | Overloaded.
GetValue | Get the current value of a particular setting.
Init | Initialize the class.
LoadSettings | Overloaded.
RemoveSettings | Overloaded.
SetValue | Set a value in the configuration.
WriteSettings | Overloaded.

See Also

PdfSettings Class


GetSettingsFilePath Method

[image] [image]

.NET Framework Class Library
PdfSettings..::.GetSettingsFilePath Method
PdfSettings Class See Also

Overload List

Name | Description
GetSettingsFilePath(PdfSettingsFileType) | Get the full file path of the settings file.
GetSettingsFilePath(Boolean) | Get the full file path of the settings file.
GetSettingsFilePath(PdfSettingsFileType, String) | Get the full file path of the settings file.

See Also

PdfSettings Class
PdfSettings Members


GetSettingsFilePath Method (PdfSettingsFileType)

[image]

.NET Framework Class Library
PdfSettings..::.GetSettingsFilePath Method (PdfSettingsFileType)
PdfSettings Class See Also

Get the full file path of the settings file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSettingsFilePath ( _
    settingsFileType As PdfSettingsFileType _
) As String
C#
public string GetSettingsFilePath(
    PdfSettingsFileType settingsFileType
)
Visual C++
public:
String^ GetSettingsFilePath(
    PdfSettingsFileType settingsFileType
)
JavaScript
function getSettingsFilePath(settingsFileType);

Parameters

settingsFileType
Type: bioPDF.PdfWriter..::.PdfSettingsFileType
Type of settings file you want the path for.

Return Value

Full path of settings file.

See Also

PdfSettings Class
GetSettingsFilePath Overload


GetSettingsFilePath Method (Boolean)

[image]

.NET Framework Class Library
PdfSettings..::.GetSettingsFilePath Method (Boolean)
PdfSettings Class See Also

Get the full file path of the settings file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSettingsFilePath ( _
    isRunOnce As Boolean _
) As String
C#
public string GetSettingsFilePath(
    bool isRunOnce
)
Visual C++
public:
String^ GetSettingsFilePath(
    bool isRunOnce
)
JavaScript
function getSettingsFilePath(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean
Indicates if you are working on the runonce or settings ini file.

See Also

PdfSettings Class
GetSettingsFilePath Overload


GetSettingsFilePath Method (PdfSettingsFileType, String)

[image]

.NET Framework Class Library
PdfSettings..::.GetSettingsFilePath Method (PdfSettingsFileType, String)
PdfSettings Class See Also

Get the full file path of the settings file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSettingsFilePath ( _
    settingsFileType As PdfSettingsFileType, _
    documentName As String _
) As String
C#
public string GetSettingsFilePath(
    PdfSettingsFileType settingsFileType,
    string documentName
)
Visual C++
public:
String^ GetSettingsFilePath(
    PdfSettingsFileType settingsFileType,
    String^ documentName
)
JavaScript
function getSettingsFilePath(settingsFileType, documentName);

Parameters

settingsFileType
Type: bioPDF.PdfWriter..::.PdfSettingsFileType
Type of settings file you want the path for.
documentName
Type: System..::.String
Name of document that this settings file must work with.

Return Value

Full path of settings file.

See Also

PdfSettings Class
GetSettingsFilePath Overload


GetValue Method

[image]

.NET Framework Class Library
PdfSettings..::.GetValue Method
PdfSettings Class See Also

Get the current value of a particular setting.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue ( _
    configName As String _
) As String
C#
public string GetValue(
    string configName
)
Visual C++
public:
String^ GetValue(
    String^ configName
)
JavaScript
function getValue(configName);

Parameters

configName
Type: System..::.String
Name of the configuration to get.

Return Value

The value of the setting.

See Also

PdfSettings Class
bioPDF.PdfWriter Namespace
PdfSettings..::.SetValue(String, String)


Init Method

[image]

.NET Framework Class Library
PdfSettings..::.Init Method
PdfSettings Class See Also

Initialize the class.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub Init
C#
public void Init()
Visual C++
public:
void Init()
JavaScript
function init();

Remarks

You can call this function to reset the component to the initial state.

See Also

PdfSettings Class


LoadSettings Method

[image] [image]

.NET Framework Class Library
PdfSettings..::.LoadSettings Method
PdfSettings Class See Also

Overload List

Name | Description
LoadSettings()()() | Read the existing runonce@printername.ini into memory.
LoadSettings(PdfSettingsFileType) | Read an existing settings file into memory.
LoadSettings(Boolean) | Read the existing settings@printername.ini or runonce@printername.ini into memory.
LoadSettings(String) | Read an existing settings file into memory.

See Also

PdfSettings Class
PdfSettings Members


LoadSettings Method

[image]

.NET Framework Class Library
PdfSettings..::.LoadSettings Method
PdfSettings Class See Also

Read the existing runonce@printername.ini into memory.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadSettings
C#
public void LoadSettings()
Visual C++
public:
void LoadSettings()
JavaScript
function loadSettings();

Remarks

If the configuration doesn't exist during the load an empty configuration will be the result. This means that you don't have to know if a configuration exists before you try to load it.

See Also

PdfSettings Class
LoadSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.WriteSettings()()()
PdfSettings..::.RemoveSettings()()()


LoadSettings Method (PdfSettingsFileType)

[image]

.NET Framework Class Library
PdfSettings..::.LoadSettings Method (PdfSettingsFileType)
PdfSettings Class See Also

Read an existing settings file into memory.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadSettings ( _
    settingsFileType As PdfSettingsFileType _
)
C#
public void LoadSettings(
    PdfSettingsFileType settingsFileType
)
Visual C++
public:
void LoadSettings(
    PdfSettingsFileType settingsFileType
)
JavaScript
function loadSettings(settingsFileType);

Parameters

settingsFileType
Type: bioPDF.PdfWriter..::.PdfSettingsFileType
The type of settings file you want to read.

Remarks

If the configuration doesn't exist during the load an empty configuration will be the result. This means that you don't have to know if a configuration exists before you try to load it.

See Also

PdfSettings Class
LoadSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.WriteSettings()()()
PdfSettings..::.RemoveSettings()()()


LoadSettings Method (Boolean)

[image]

.NET Framework Class Library
PdfSettings..::.LoadSettings Method (Boolean)
PdfSettings Class See Also

Read the existing settings@printername.ini or runonce@printername.ini into memory.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadSettings ( _
    isRunOnce As Boolean _
)
C#
public void LoadSettings(
    bool isRunOnce
)
Visual C++
public:
void LoadSettings(
    bool isRunOnce
)
JavaScript
function loadSettings(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean
Indicates if you are working on the runonce@printername.ini or settings@printername.ini file.

Remarks

If the configuration doesn't exist during the load an empty configuration will be the result. This means that you don't have to know if a configuration exists before you try to load it.

See Also

PdfSettings Class
LoadSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.WriteSettings()()()
PdfSettings..::.RemoveSettings()()()


LoadSettings Method (String)

[image]

.NET Framework Class Library
PdfSettings..::.LoadSettings Method (String)
PdfSettings Class See Also

Read an existing settings file into memory.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadSettings ( _
    fileName As String _
)
C#
public void LoadSettings(
    string fileName
)
Visual C++
public:
void LoadSettings(
    String^ fileName
)
JavaScript
function loadSettings(fileName);

Parameters

fileName
Type: System..::.String
Full file path of the settings file you want to read.

Remarks

If the configuration doesn't exist during the load an empty configuration will be the result. This means that you don't have to know if a configuration exists before you try to load it.

See Also

PdfSettings Class
LoadSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.WriteSettings()()()
PdfSettings..::.RemoveSettings()()()


RemoveSettings Method

[image] [image]

.NET Framework Class Library
PdfSettings..::.RemoveSettings Method
PdfSettings Class See Also

Overload List

Name | Description
RemoveSettings()()() | Removes an existing settings@printername.ini or runonce@printername.ini.
RemoveSettings(PdfSettingsFileType) | Removes an existing settings file.
RemoveSettings(Boolean) | Removes an existing settings@printername.ini or runonce@printername.ini.
RemoveSettings(String) | Removes an existing settings file.

See Also

PdfSettings Class
PdfSettings Members


RemoveSettings Method

[image]

.NET Framework Class Library
PdfSettings..::.RemoveSettings Method
PdfSettings Class See Also

Removes an existing settings@printername.ini or runonce@printername.ini.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveSettings
C#
public void RemoveSettings()
Visual C++
public:
void RemoveSettings()
JavaScript
function removeSettings();

See Also

PdfSettings Class
RemoveSettings Overload


RemoveSettings Method (PdfSettingsFileType)

[image]

.NET Framework Class Library
PdfSettings..::.RemoveSettings Method (PdfSettingsFileType)
PdfSettings Class See Also

Removes an existing settings file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveSettings ( _
    settingsFileType As PdfSettingsFileType _
)
C#
public void RemoveSettings(
    PdfSettingsFileType settingsFileType
)
Visual C++
public:
void RemoveSettings(
    PdfSettingsFileType settingsFileType
)
JavaScript
function removeSettings(settingsFileType);

Parameters

settingsFileType
Type: bioPDF.PdfWriter..::.PdfSettingsFileType
Indicates if type of settings file you want to remove.

Remarks

If the file you are trying to delete doesn't exist, nothing will happen.

See Also

PdfSettings Class
RemoveSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.LoadSettings()()()
PdfSettings..::.WriteSettings()()()


RemoveSettings Method (Boolean)

[image]

.NET Framework Class Library
PdfSettings..::.RemoveSettings Method (Boolean)
PdfSettings Class See Also

Removes an existing settings@printername.ini or runonce@printername.ini.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveSettings ( _
    isRunOnce As Boolean _
)
C#
public void RemoveSettings(
    bool isRunOnce
)
Visual C++
public:
void RemoveSettings(
    bool isRunOnce
)
JavaScript
function removeSettings(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean
Indicates if you are working on the runonce@printername.ini or settings@printername.ini file.

Remarks

If the file you are trying to delete doesn't exist, nothing will happen.

See Also

PdfSettings Class
RemoveSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.LoadSettings()()()
PdfSettings..::.WriteSettings()()()


RemoveSettings Method (String)

[image]

.NET Framework Class Library
PdfSettings..::.RemoveSettings Method (String)
PdfSettings Class See Also

Removes an existing settings file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveSettings ( _
    fileName As String _
)
C#
public void RemoveSettings(
    string fileName
)
Visual C++
public:
void RemoveSettings(
    String^ fileName
)
JavaScript
function removeSettings(fileName);

Parameters

fileName
Type: System..::.String
Indicates the file name of the settings file you want to remove.

Remarks

If the file you are trying to delete doesn't exist, nothing will happen.

See Also

PdfSettings Class
RemoveSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.LoadSettings()()()
PdfSettings..::.WriteSettings()()()


SetValue Method

[image]

.NET Framework Class Library
PdfSettings..::.SetValue Method
PdfSettings Class Example See Also

Set a value in the configuration.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetValue ( _
    configName As String, _
    configValue As String _
)
C#
public void SetValue(
    string configName,
    string configValue
)
Visual C++
public:
void SetValue(
    String^ configName,
    String^ configValue
)
JavaScript
function setValue(configName, configValue);

Parameters

configName
Type: System..::.String
Name of the configuration to set.
configValue
Type: System..::.String
Value of the configuration.

Remarks

A call to this function can be used to change all the printer settings such as the output path.

Examples

Changing the output would look something like SetValue("output", "c:\myfile.pdf").

See Also

PdfSettings Class
bioPDF.PdfWriter Namespace
PdfSettings..::.GetValue(String)


WriteSettings Method

[image] [image]

.NET Framework Class Library
PdfSettings..::.WriteSettings Method
PdfSettings Class See Also

Overload List

Name | Description
WriteSettings()()() | Save the settings to the runonce@printername.ini file.
WriteSettings(PdfSettingsFileType) | Save the settings to file.
WriteSettings(Boolean) | Save the settings to the runonce@printername.ini or settings@printername.ini file.
WriteSettings(String) | Save the settings to file.

See Also

PdfSettings Class
PdfSettings Members


WriteSettings Method

[image]

.NET Framework Class Library
PdfSettings..::.WriteSettings Method
PdfSettings Class See Also

Save the settings to the runonce@printername.ini file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteSettings
C#
public void WriteSettings()
Visual C++
public:
void WriteSettings()
JavaScript
function writeSettings();

Remarks

An exception is raised if the write operation fails.

See Also

PdfSettings Class
WriteSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.LoadSettings()()()
PdfSettings..::.RemoveSettings()()()


WriteSettings Method (PdfSettingsFileType)

[image]

.NET Framework Class Library
PdfSettings..::.WriteSettings Method (PdfSettingsFileType)
PdfSettings Class See Also

Save the settings to file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteSettings ( _
    settingsFileType As PdfSettingsFileType _
)
C#
public void WriteSettings(
    PdfSettingsFileType settingsFileType
)
Visual C++
public:
void WriteSettings(
    PdfSettingsFileType settingsFileType
)
JavaScript
function writeSettings(settingsFileType);

Parameters

settingsFileType
Type: bioPDF.PdfWriter..::.PdfSettingsFileType
The type of settings file you want to write.

Remarks

An exception is raised if the write operation fails.

See Also

PdfSettings Class
WriteSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.LoadSettings()()()
PdfSettings..::.RemoveSettings()()()


WriteSettings Method (Boolean)

[image]

.NET Framework Class Library
PdfSettings..::.WriteSettings Method (Boolean)
PdfSettings Class See Also

Save the settings to the runonce@printername.ini or settings@printername.ini file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteSettings ( _
    isRunOnce As Boolean _
)
C#
public void WriteSettings(
    bool isRunOnce
)
Visual C++
public:
void WriteSettings(
    bool isRunOnce
)
JavaScript
function writeSettings(isRunOnce);

Parameters

isRunOnce
Type: System..::.Boolean
Indicates if you are working on the runonce@printername.ini or settings@printername.ini file.

Remarks

An exception is raised if the write operation fails.

See Also

PdfSettings Class
WriteSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.LoadSettings()()()
PdfSettings..::.RemoveSettings()()()


WriteSettings Method (String)

[image]

.NET Framework Class Library
PdfSettings..::.WriteSettings Method (String)
PdfSettings Class See Also

Save the settings to file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteSettings ( _
    fileName As String _
)
C#
public void WriteSettings(
    string fileName
)
Visual C++
public:
void WriteSettings(
    String^ fileName
)
JavaScript
function writeSettings(fileName);

Parameters

fileName
Type: System..::.String
Full file path of the file you want to write.

Remarks

An exception is raised if the write operation fails.

See Also

PdfSettings Class
WriteSettings Overload
bioPDF.PdfWriter Namespace
PdfSettings..::.LoadSettings()()()
PdfSettings..::.RemoveSettings()()()


PdfSettings Properties

[image] [image]

.NET Framework Class Library
PdfSettings Properties
PdfSettings Class See Also

The PdfSettings type exposes the following members.

Properties

Name | Description
PrinterName | Specify which printer name the current settnings applies to.
PrinterVersion | Returns the version of the installed printer. It looks at the version information of gui.exe in the printer's program folder.
Version | The version of the assembly. This is not the same as the version of the printer.

See Also

PdfSettings Class


PrinterName Property

[image]

.NET Framework Class Library
PdfSettings..::.PrinterName Property
PdfSettings Class See Also

Specify which printer name the current settnings applies to.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Property PrinterName As String
C#
public string PrinterName { get; set; }
Visual C++
public:
property String^ PrinterName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_printerName();
function set_printerName(value);

Remarks

Many of the methods in this class requires that a valid printer name is set using this property.

See Also

PdfSettings Class


PrinterVersion Property

[image]

.NET Framework Class Library
PdfSettings..::.PrinterVersion Property
PdfSettings Class See Also

Returns the version of the installed printer. It looks at the version information of gui.exe in the printer's program folder.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrinterVersion As String
C#
public string PrinterVersion { get; }
Visual C++
public:
property String^ PrinterVersion {
    String^ get ();
}
JavaScript
function get_printerVersion();

See Also

PdfSettings Class


Version Property

[image]

.NET Framework Class Library
PdfSettings..::.Version Property
PdfSettings Class See Also

The version of the assembly. This is not the same as the version of the printer.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As String
C#
public string Version { get; }
Visual C++
public:
property String^ Version {
    String^ get ();
}
JavaScript
function get_version();

See Also

PdfSettings Class


PdfSettingsFileType Enumeration

[image]

.NET Framework Class Library
PdfSettingsFileType Enumeration
See Also

Types of settings files.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PdfSettingsFileType
C#
public enum PdfSettingsFileType
Visual C++
public enum class PdfSettingsFileType
JavaScript
bioPDF.PdfWriter.PdfSettingsFileType = function();
bioPDF.PdfWriter.PdfSettingsFileType.createEnum('bioPDF.PdfWriter.PdfSettingsFileType', false);

Members

Member name | Description
Settings | Normal settings file written by the options dialog in the start menu.
User | User settings such as last used folder and file name.
RunOnce | Temporary settings file used for programatic control of the printer.
Global | Global settings that override all other settings except those of the RunOnce settings file.
Defaults | Default values.

See Also

bioPDF.PdfWriter Namespace


PdfUtil Class

[image]

.NET Framework Class Library
PdfUtil Class
Members See Also

Helper class for creating PDF files.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Class PdfUtil
C#
public class PdfUtil
Visual C++
public ref class PdfUtil
JavaScript
bioPDF.PdfWriter.PdfUtil = function();

Type.createClass(
    'bioPDF.PdfWriter.PdfUtil');

Inheritance Hierarchy

System..::.Object
bioPDF.PdfWriter..::.PdfUtil

See Also

PdfUtil Members


PdfUtil Members

[image] [image]

.NET Framework Class Library
PdfUtil Members
PdfUtil Class Constructors Methods Properties See Also

The PdfUtil type exposes the following members.

Constructors

Name | Description
PdfUtil |

Methods

Name | Description
DecryptSetting
Decrypt Unicode string.
EncryptPdf
Encrypt an existing PDF
EncryptSetting
Encrypt Unicode string.
GetCompatiblePrinters
Get list of compatible printers
GetPrinterAppFolder
Get the application folder of the specified printer.
GetPrinterVersion
Get the version of the printer.
GetPrinterVersionInfo
Get the version information of the printer.
GetRegistrySetting
Read printer settings from the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers\[PRINTER NAME]
Linearize | Overloaded.
Merge
Merge two or more PDF files.
PrintFile
Send a file to the printer set in the PrinterName property. This method will use the PrintTo verb to send a file to the printer and create a PDF document. You often want to create a runonce.ini before calling this method. It is recommended that you set the following settings:
Copy Code
ShowSettings=never
Copy Code
ShowSaveAs=never
Copy Code
ShowProgress=yes
Copy Code
ShowProgressFinished=no
Copy Code
ShowPDF=no
Copy Code
ConfirmOverwrite=no
PrintPdf
Send an existing PDF file to a printer
ReadIniString
Read a string from an ini file.
SignPdf | Overloaded.
SignPdfByThumbprint | Overloaded.
WaitForFile
Wait for a file to be created.
WriteIniString
Write a string to an ini file.

Properties

Name | Description
DefaultPrinterName | Returns the default printer name for the assembly.

See Also

PdfUtil Class


PdfUtil Constructor

[image]

.NET Framework Class Library
PdfUtil Constructor
PdfUtil Class See Also

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdfUtil()
Visual C++
public:
PdfUtil()
JavaScript
bioPDF.PdfWriter.PdfUtil = function();

See Also

PdfUtil Class


PdfUtil Methods

[image] [image]

.NET Framework Class Library
PdfUtil Methods
PdfUtil Class See Also

The PdfUtil type exposes the following members.

Methods

Name | Description
DecryptSetting
Decrypt Unicode string.
EncryptPdf
Encrypt an existing PDF
EncryptSetting
Encrypt Unicode string.
GetCompatiblePrinters
Get list of compatible printers
GetPrinterAppFolder
Get the application folder of the specified printer.
GetPrinterVersion
Get the version of the printer.
GetPrinterVersionInfo
Get the version information of the printer.
GetRegistrySetting
Read printer settings from the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers\[PRINTER NAME]
Linearize | Overloaded.
Merge
Merge two or more PDF files.
PrintFile
Send a file to the printer set in the PrinterName property. This method will use the PrintTo verb to send a file to the printer and create a PDF document. You often want to create a runonce.ini before calling this method. It is recommended that you set the following settings:
Copy Code
ShowSettings=never
Copy Code
ShowSaveAs=never
Copy Code
ShowProgress=yes
Copy Code
ShowProgressFinished=no
Copy Code
ShowPDF=no
Copy Code
ConfirmOverwrite=no
PrintPdf
Send an existing PDF file to a printer
ReadIniString
Read a string from an ini file.
SignPdf | Overloaded.
SignPdfByThumbprint | Overloaded.
WaitForFile
Wait for a file to be created.
WriteIniString
Write a string to an ini file.

See Also

PdfUtil Class


DecryptSetting Method

[image]

.NET Framework Class Library
PdfUtil..::.DecryptSetting Method
PdfUtil Class See Also

Decrypt Unicode string.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function DecryptSetting ( _
    input As String _
) As String
C#
public static string DecryptSetting(
    string input
)
Visual C++
public:
static String^ DecryptSetting(
    String^ input
)
JavaScript
bioPDF.PdfWriter.PdfUtil.decryptSetting = function(input);

Parameters

input
Type: System..::.String
Encrypted string.

Return Value

Decrypted Unicode string.

See Also

PdfUtil Class


EncryptPdf Method

[image]

.NET Framework Class Library
PdfUtil..::.EncryptPdf Method
PdfUtil Class See Also

Encrypt an existing PDF

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub EncryptPdf ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    ownerPassword As String, _
    userPassword As String, _
    encryptionType As PdfUtil..::.EncryptionType, _
    allowAssembly As Boolean, _
    allowCopy As Boolean, _
    allowDegradedPrinting As Boolean, _
    allowFillIn As Boolean, _
    allowModifyAnnotations As Boolean, _
    allowModifyContents As Boolean, _
    allowPrinting As Boolean, _
    allowScreenReaders As Boolean _
)
C#
public static void EncryptPdf(
    string printerName,
    string inputFileName,
    string outputFileName,
    string ownerPassword,
    string userPassword,
    PdfUtil..::.EncryptionType encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
Visual C++
public:
static void EncryptPdf(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ ownerPassword,
    String^ userPassword,
    PdfUtil..::.EncryptionType encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
JavaScript
bioPDF.PdfWriter.PdfUtil.encryptPdf = function(printerName, inputFileName, outputFileName, ownerPassword, userPassword, encryptionType, allowAssembly, allowCopy, allowDegradedPrinting, allowFillIn, allowModifyAnnotations, allowModifyContents, allowPrinting, allowScreenReaders);

Parameters

printerName
Type: System..::.String
Name of PDF printer
inputFileName
Type: System..::.String
Full path of file to encrypt.
outputFileName
Type: System..::.String
Full path of output file.
ownerPassword
Type: System..::.String
Owner password for PDF encryption.
userPassword
Type: System..::.String
User password for PDF encryption.
encryptionType
Type: bioPDF.PdfWriter..::.PdfUtil..::.EncryptionType
Type and streangth of encryption.
allowAssembly
Type: System..::.Boolean
Allow assembly.
allowCopy
Type: System..::.Boolean
Allow copy to clipboard.
allowDegradedPrinting
Type: System..::.Boolean
Allow degraded printing.
allowFillIn
Type: System..::.Boolean
Allow fill in.
allowModifyAnnotations
Type: System..::.Boolean
Allow modifying annotations.
allowModifyContents
Type: System..::.Boolean
Allow modifying contents.
allowPrinting
Type: System..::.Boolean
Allow printing.
allowScreenReaders
Type: System..::.Boolean
Allow screen readers.

See Also

PdfUtil Class


EncryptSetting Method

[image]

.NET Framework Class Library
PdfUtil..::.EncryptSetting Method
PdfUtil Class See Also

Encrypt Unicode string.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EncryptSetting ( _
    input As String _
) As String
C#
public static string EncryptSetting(
    string input
)
Visual C++
public:
static String^ EncryptSetting(
    String^ input
)
JavaScript
bioPDF.PdfWriter.PdfUtil.encryptSetting = function(input);

Parameters

input
Type: System..::.String
Unicode string to encrypt.

Return Value

Encrypted Unicode string.

See Also

PdfUtil Class


GetCompatiblePrinters Method

[image]

.NET Framework Class Library
PdfUtil..::.GetCompatiblePrinters Method
PdfUtil Class See Also

Get list of compatible printers

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCompatiblePrinters As String()
C#
public static string[] GetCompatiblePrinters()
Visual C++
public:
static array<String^>^ GetCompatiblePrinters()
JavaScript
bioPDF.PdfWriter.PdfUtil.getCompatiblePrinters = function();

Return Value

Array of compatible printers

See Also

PdfUtil Class


GetPrinterAppFolder Method

[image]

.NET Framework Class Library
PdfUtil..::.GetPrinterAppFolder Method
PdfUtil Class See Also

Get the application folder of the specified printer.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPrinterAppFolder ( _
    printerName As String _
) As String
C#
public static string GetPrinterAppFolder(
    string printerName
)
Visual C++
public:
static String^ GetPrinterAppFolder(
    String^ printerName
)
JavaScript
bioPDF.PdfWriter.PdfUtil.getPrinterAppFolder = function(printerName);

Parameters

printerName
Type: System..::.String
Name of printer.

Return Value

The return value is the location of the program executables that belong to the printer.

See Also

PdfUtil Class


GetPrinterVersion Method

[image]

.NET Framework Class Library
PdfUtil..::.GetPrinterVersion Method
PdfUtil Class See Also

Get the version of the printer.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPrinterVersion ( _
    printerName As String _
) As String
C#
public static string GetPrinterVersion(
    string printerName
)
Visual C++
public:
static String^ GetPrinterVersion(
    String^ printerName
)
JavaScript
bioPDF.PdfWriter.PdfUtil.getPrinterVersion = function(printerName);

Parameters

printerName
Type: System..::.String

Return Value

The full version number of the printer in the form x.x.x.x.

See Also

PdfUtil Class


GetPrinterVersionInfo Method

[image]

.NET Framework Class Library
PdfUtil..::.GetPrinterVersionInfo Method
PdfUtil Class See Also

Get the version information of the printer.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPrinterVersionInfo ( _
    printerName As String _
) As FileVersionInfo
C#
public static FileVersionInfo GetPrinterVersionInfo(
    string printerName
)
Visual C++
public:
static FileVersionInfo^ GetPrinterVersionInfo(
    String^ printerName
)
JavaScript
bioPDF.PdfWriter.PdfUtil.getPrinterVersionInfo = function(printerName);

Parameters

printerName
Type: System..::.String

Return Value

An instance of the FileVersionInfo class. The return value is null if the version information couldn't be retrieved.

Remarks

The version information originates from the
Copy Code
gui.exe
executable in the program folder for the printer.

See Also

PdfUtil Class


GetRegistrySetting Method

[image]

.NET Framework Class Library
PdfUtil..::.GetRegistrySetting Method
PdfUtil Class See Also

Read printer settings from the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers\[PRINTER NAME]

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRegistrySetting ( _
    settingName As String, _
    printerName As String _
) As String
C#
public static string GetRegistrySetting(
    string settingName,
    string printerName
)
Visual C++
public:
static String^ GetRegistrySetting(
    String^ settingName,
    String^ printerName
)
JavaScript
bioPDF.PdfWriter.PdfUtil.getRegistrySetting = function(settingName, printerName);

Parameters

settingName
Type: System..::.String
Name of setting to read
printerName
Type: System..::.String
Name of printer

Return Value

The string value of the registry setting

See Also

PdfUtil Class


Linearize Method

[image] [image]

.NET Framework Class Library
PdfUtil..::.Linearize Method
PdfUtil Class See Also

Overload List

Name | Description
Linearize(String, String, String) | Linearize PDF for fast web view.
Linearize(String, String, String, Int32) | Linearize PDF for fast web view.

See Also

PdfUtil Class
PdfUtil Members


Linearize Method (String, String, String)

[image]

.NET Framework Class Library
PdfUtil..::.Linearize Method (String, String, String)
PdfUtil Class See Also

Linearize PDF for fast web view.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Linearize ( _
    inputFileName As String, _
    outputFileName As String, _
    printerName As String _
)
C#
public static void Linearize(
    string inputFileName,
    string outputFileName,
    string printerName
)
Visual C++
public:
static void Linearize(
    String^ inputFileName,
    String^ outputFileName,
    String^ printerName
)
JavaScript
bioPDF.PdfWriter.PdfUtil.linearize = function(inputFileName, outputFileName, printerName);

Parameters

inputFileName
Type: System..::.String
File name of PDF document to linearize.
outputFileName
Type: System..::.String
Name of output PDF document.
printerName
Type: System..::.String
Name of installed PDF printer. This is used to localize some of the libraries needed for this operation.

See Also

PdfUtil Class
Linearize Overload


Linearize Method (String, String, String, Int32)

[image]

.NET Framework Class Library
PdfUtil..::.Linearize Method (String, String, String, Int32)
PdfUtil Class See Also

Linearize PDF for fast web view.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Linearize ( _
    inputFileName As String, _
    outputFileName As String, _
    printerName As String, _
    timeoutMilliseconds As Integer _
)
C#
public static void Linearize(
    string inputFileName,
    string outputFileName,
    string printerName,
    int timeoutMilliseconds
)
Visual C++
public:
static void Linearize(
    String^ inputFileName,
    String^ outputFileName,
    String^ printerName,
    int timeoutMilliseconds
)
JavaScript
bioPDF.PdfWriter.PdfUtil.linearize = function(inputFileName, outputFileName, printerName, timeoutMilliseconds);

Parameters

inputFileName
Type: System..::.String
File name of PDF document to linearize.
outputFileName
Type: System..::.String
Name of output PDF document.
printerName
Type: System..::.String
Name of installed PDF printer. This is used to localize some of the libraries needed for this operation.
timeoutMilliseconds
Type: System..::.Int32
Maximum wait time for running external programs needed in the conversion.

See Also

PdfUtil Class
Linearize Overload


Merge Method

[image]

.NET Framework Class Library
PdfUtil..::.Merge Method
PdfUtil Class See Also

Merge two or more PDF files.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Merge ( _
    inputFileNames As String(), _
    outputFileName As String, _
    printerName As String, _
    timeoutMilliseconds As Integer _
)
C#
public static void Merge(
    string[] inputFileNames,
    string outputFileName,
    string printerName,
    int timeoutMilliseconds
)
Visual C++
public:
static void Merge(
    array<String^>^ inputFileNames,
    String^ outputFileName,
    String^ printerName,
    int timeoutMilliseconds
)
JavaScript
bioPDF.PdfWriter.PdfUtil.merge = function(inputFileNames, outputFileName, printerName, timeoutMilliseconds);

Parameters

inputFileNames
Type: array< System..::.String >[]()[]
Array of files to merge.
outputFileName
Type: System..::.String
Path of output file.
printerName
Type: System..::.String
Name of PDF printer.
timeoutMilliseconds
Type: System..::.Int32
Timeout in milliseconds for external processes launched during the merge operation.

See Also

PdfUtil Class


PrintFile Method

[image]

.NET Framework Class Library
PdfUtil..::.PrintFile Method
PdfUtil Class See Also

Send a file to the printer set in the PrinterName property. This method will use the PrintTo verb to send a file to the printer and create a PDF document. You often want to create a runonce.ini before calling this method. It is recommended that you set the following settings:
Copy Code
ShowSettings=never
Copy Code
ShowSaveAs=never
Copy Code
ShowProgress=yes
Copy Code
ShowProgressFinished=no
Copy Code
ShowPDF=no
Copy Code
ConfirmOverwrite=no

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function PrintFile ( _
    fileName As String, _
    printerName As String _
) As Boolean
C#
public static bool PrintFile(
    string fileName,
    string printerName
)
Visual C++
public:
static bool PrintFile(
    String^ fileName,
    String^ printerName
)
JavaScript
bioPDF.PdfWriter.PdfUtil.printFile = function(fileName, printerName);

Parameters

fileName
Type: System..::.String
Full path of document to print.
printerName
Type: System..::.String
Name of printer to be used from this method.

Return Value

Returns true if the document was sent to the printer. Otherwise, it returns false.

Remarks

This method uses the printto verb to send the document to the printer. It requires that there is an association between the file type you specify and a printto verb.

See Also

PdfUtil Class
bioPDF.PdfWriter Namespace
PdfUtil..::.WaitForFile(String, Int32)


PrintPdf Method

[image]

.NET Framework Class Library
PdfUtil..::.PrintPdf Method
PdfUtil Class See Also

Send an existing PDF file to a printer

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub PrintPdf ( _
    pdfFileName As String, _
    printerSelection As PdfUtil..::.PrinterSelection, _
    printToPrinterName As String, _
    pdfPrinterName As String, _
    showProgress As Boolean, _
    bitsPerPixel As Integer, _
    documentName As String, _
    maxResolution As Integer, _
    scaleToFit As Boolean, _
    firstPage As Integer, _
    lastPage As Integer, _
    timeoutMilliseconds As Integer _
)
C#
public static void PrintPdf(
    string pdfFileName,
    PdfUtil..::.PrinterSelection printerSelection,
    string printToPrinterName,
    string pdfPrinterName,
    bool showProgress,
    int bitsPerPixel,
    string documentName,
    int maxResolution,
    bool scaleToFit,
    int firstPage,
    int lastPage,
    int timeoutMilliseconds
)
Visual C++
public:
static void PrintPdf(
    String^ pdfFileName,
    PdfUtil..::.PrinterSelection printerSelection,
    String^ printToPrinterName,
    String^ pdfPrinterName,
    bool showProgress,
    int bitsPerPixel,
    String^ documentName,
    int maxResolution,
    bool scaleToFit,
    int firstPage,
    int lastPage,
    int timeoutMilliseconds
)
JavaScript
bioPDF.PdfWriter.PdfUtil.printPdf = function(pdfFileName, printerSelection, printToPrinterName, pdfPrinterName, showProgress, bitsPerPixel, documentName, maxResolution, scaleToFit, firstPage, lastPage, timeoutMilliseconds);

Parameters

pdfFileName
Type: System..::.String
Full path to PDF file to print.
printerSelection
Type: bioPDF.PdfWriter..::.PdfUtil..::.PrinterSelection
How the printer will be selected.
printToPrinterName
Type: System..::.String
Name of printer to print to if a specific printer is used.
pdfPrinterName
Type: System..::.String
Name of PDF printer that this API is linked to.
showProgress
Type: System..::.Boolean
Show render progress.
bitsPerPixel
Type: System..::.Int32
Valid values are 1, 4, 8, 24.
documentName
Type: System..::.String
Name of document in spooler queue.
maxResolution
Type: System..::.Int32
Maximum DPI resolution for print job.
scaleToFit
Type: System..::.Boolean
Scale the content to fit the paper.
firstPage
Type: System..::.Int32
Page number of first page to print.
lastPage
Type: System..::.Int32
Page number of last page to print. 0 is default and will print all pages after the first selected page.
timeoutMilliseconds
Type: System..::.Int32
Maximum time to wait for print job to render.

See Also

PdfUtil Class


ReadIniString Method

[image]

.NET Framework Class Library
PdfUtil..::.ReadIniString Method
PdfUtil Class See Also

Read a string from an ini file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReadIniString ( _
    fileName As String, _
    sectionName As String, _
    valueName As String, _
    defaultValue As String _
) As String
C#
public static string ReadIniString(
    string fileName,
    string sectionName,
    string valueName,
    string defaultValue
)
Visual C++
public:
static String^ ReadIniString(
    String^ fileName,
    String^ sectionName,
    String^ valueName,
    String^ defaultValue
)
JavaScript
bioPDF.PdfWriter.PdfUtil.readIniString = function(fileName, sectionName, valueName, defaultValue);

Parameters

fileName
Type: System..::.String
File name of ini file.
sectionName
Type: System..::.String
Name of section in ini file.
valueName
Type: System..::.String
Name of value in section.
defaultValue
Type: System..::.String
Default value to return if value was not found.

Return Value

See Also

PdfUtil Class


SignPdf Method

[image] [image]

.NET Framework Class Library
PdfUtil..::.SignPdf Method
PdfUtil Class See Also

Overload List

Name | Description
SignPdf(String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32) | Apply a digital signature to a PDF document.
SignPdf(String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32, String, String, PdfUtil..::.EncryptionType, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Apply a digital signature to a PDF document.

See Also

PdfUtil Class
PdfUtil Members


SignPdf Method (String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32)

[image]

.NET Framework Class Library
PdfUtil..::.SignPdf Method (String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32)
PdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SignPdf ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateFileName As String, _
    certificatePassword As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer _
)
C#
public static void SignPdf(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateFileName,
    string certificatePassword,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
)
Visual C++
public:
static void SignPdf(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateFileName,
    String^ certificatePassword,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
)
JavaScript
bioPDF.PdfWriter.PdfUtil.signPdf = function(printerName, inputFileName, outputFileName, certificateFileName, certificatePassword, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateFileName
Type: System..::.String
File name of the PFX certificate file
certificatePassword
Type: System..::.String
Certificate private key password
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.

See Also

PdfUtil Class
SignPdf Overload


SignPdf Method (String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32, String, String, PdfUtil.EncryptionType, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

.NET Framework Class Library
PdfUtil..::.SignPdf Method (String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32, String, String, PdfUtil..::.EncryptionType, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
PdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SignPdf ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateFileName As String, _
    certificatePassword As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer, _
    ownerPassword As String, _
    userPassword As String, _
    encryptionType As PdfUtil..::.EncryptionType, _
    allowAssembly As Boolean, _
    allowCopy As Boolean, _
    allowDegradedPrinting As Boolean, _
    allowFillIn As Boolean, _
    allowModifyAnnotations As Boolean, _
    allowModifyContents As Boolean, _
    allowPrinting As Boolean, _
    allowScreenReaders As Boolean _
)
C#
public static void SignPdf(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateFileName,
    string certificatePassword,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    string ownerPassword,
    string userPassword,
    PdfUtil..::.EncryptionType encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
Visual C++
public:
static void SignPdf(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateFileName,
    String^ certificatePassword,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    String^ ownerPassword,
    String^ userPassword,
    PdfUtil..::.EncryptionType encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
JavaScript
bioPDF.PdfWriter.PdfUtil.signPdf = function(printerName, inputFileName, outputFileName, certificateFileName, certificatePassword, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage, ownerPassword, userPassword, encryptionType, allowAssembly, allowCopy, allowDegradedPrinting, allowFillIn, allowModifyAnnotations, allowModifyContents, allowPrinting, allowScreenReaders);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateFileName
Type: System..::.String
File name of the PFX certificate file
certificatePassword
Type: System..::.String
Certificate private key password
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.
ownerPassword
Type: System..::.String
Owner password for PDF encryption.
userPassword
Type: System..::.String
User password for PDF encryption.
encryptionType
Type: bioPDF.PdfWriter..::.PdfUtil..::.EncryptionType
Type and streangth of encryption.
allowAssembly
Type: System..::.Boolean
Allow assembly.
allowCopy
Type: System..::.Boolean
Allow copy to clipboard.
allowDegradedPrinting
Type: System..::.Boolean
Allow degraded printing.
allowFillIn
Type: System..::.Boolean
Allow fill in.
allowModifyAnnotations
Type: System..::.Boolean
Allow modifying annotations.
allowModifyContents
Type: System..::.Boolean
Allow modifying contents.
allowPrinting
Type: System..::.Boolean
Allow printing.
allowScreenReaders
Type: System..::.Boolean
Allow screen readers.

See Also

PdfUtil Class
SignPdf Overload


SignPdfByThumbprint Method

[image] [image]

.NET Framework Class Library
PdfUtil..::.SignPdfByThumbprint Method
PdfUtil Class See Also

Overload List

Name | Description
SignPdfByThumbprint(String, String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32) | Apply a digital signature to a PDF document.
SignPdfByThumbprint(String, String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32, String, String, PdfUtil..::.EncryptionType, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Apply a digital signature to a PDF document.

See Also

PdfUtil Class
PdfUtil Members


SignPdfByThumbprint Method (String, String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32)

[image]

.NET Framework Class Library
PdfUtil..::.SignPdfByThumbprint Method (String, String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32)
PdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SignPdfByThumbprint ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateThumbprint As String, _
    certificateStoreName As String, _
    certificateStoreLocation As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer _
)
C#
public static void SignPdfByThumbprint(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateThumbprint,
    string certificateStoreName,
    string certificateStoreLocation,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
)
Visual C++
public:
static void SignPdfByThumbprint(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateThumbprint,
    String^ certificateStoreName,
    String^ certificateStoreLocation,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage
)
JavaScript
bioPDF.PdfWriter.PdfUtil.signPdfByThumbprint = function(printerName, inputFileName, outputFileName, certificateThumbprint, certificateStoreName, certificateStoreLocation, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateThumbprint
Type: System..::.String
Thumbprint string of certificate in the certificate store.
certificateStoreName
Type: System..::.String
Name of the certificate store (AddressBook, AuthRoot, CertificateAuthority, Disallowed, My (default), Root, TrustedPeople, TrustedPublisher)
certificateStoreLocation
Type: System..::.String
Location of the certificate store (CurrentUser (default), LocalMachine).
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.

See Also

PdfUtil Class
SignPdfByThumbprint Overload


SignPdfByThumbprint Method (String, String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32, String, String, PdfUtil.EncryptionType, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

.NET Framework Class Library
PdfUtil..::.SignPdfByThumbprint Method (String, String, String, String, String, String, String, String, String, Boolean, Single, Single, Single, Single, Int32, String, String, PdfUtil..::.EncryptionType, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
PdfUtil Class See Also

Apply a digital signature to a PDF document.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SignPdfByThumbprint ( _
    printerName As String, _
    inputFileName As String, _
    outputFileName As String, _
    certificateThumbprint As String, _
    certificateStoreName As String, _
    certificateStoreLocation As String, _
    signReason As String, _
    signContact As String, _
    signLocation As String, _
    displaySignature As Boolean, _
    signLLX As Single, _
    signLLY As Single, _
    signRUX As Single, _
    signRUY As Single, _
    signPage As Integer, _
    ownerPassword As String, _
    userPassword As String, _
    encryptionType As PdfUtil..::.EncryptionType, _
    allowAssembly As Boolean, _
    allowCopy As Boolean, _
    allowDegradedPrinting As Boolean, _
    allowFillIn As Boolean, _
    allowModifyAnnotations As Boolean, _
    allowModifyContents As Boolean, _
    allowPrinting As Boolean, _
    allowScreenReaders As Boolean _
)
C#
public static void SignPdfByThumbprint(
    string printerName,
    string inputFileName,
    string outputFileName,
    string certificateThumbprint,
    string certificateStoreName,
    string certificateStoreLocation,
    string signReason,
    string signContact,
    string signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    string ownerPassword,
    string userPassword,
    PdfUtil..::.EncryptionType encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
Visual C++
public:
static void SignPdfByThumbprint(
    String^ printerName,
    String^ inputFileName,
    String^ outputFileName,
    String^ certificateThumbprint,
    String^ certificateStoreName,
    String^ certificateStoreLocation,
    String^ signReason,
    String^ signContact,
    String^ signLocation,
    bool displaySignature,
    float signLLX,
    float signLLY,
    float signRUX,
    float signRUY,
    int signPage,
    String^ ownerPassword,
    String^ userPassword,
    PdfUtil..::.EncryptionType encryptionType,
    bool allowAssembly,
    bool allowCopy,
    bool allowDegradedPrinting,
    bool allowFillIn,
    bool allowModifyAnnotations,
    bool allowModifyContents,
    bool allowPrinting,
    bool allowScreenReaders
)
JavaScript
bioPDF.PdfWriter.PdfUtil.signPdfByThumbprint = function(printerName, inputFileName, outputFileName, certificateThumbprint, certificateStoreName, certificateStoreLocation, signReason, signContact, signLocation, displaySignature, signLLX, signLLY, signRUX, signRUY, signPage, ownerPassword, userPassword, encryptionType, allowAssembly, allowCopy, allowDegradedPrinting, allowFillIn, allowModifyAnnotations, allowModifyContents, allowPrinting, allowScreenReaders);

Parameters

printerName
Type: System..::.String
Name of PDF printer.
inputFileName
Type: System..::.String
The PDF document you want to sign
outputFileName
Type: System..::.String
File name of the resulting signed document
certificateThumbprint
Type: System..::.String
Thumbprint string of certificate in the certificate store.
certificateStoreName
Type: System..::.String
Name of the certificate store (AddressBook, AuthRoot, CertificateAuthority, Disallowed, My (default), Root, TrustedPeople, TrustedPublisher)
certificateStoreLocation
Type: System..::.String
Location of the certificate store (CurrentUser (default), LocalMachine).
signReason
Type: System..::.String
Optional sign reason
signContact
Type: System..::.String
Optional sign contact
signLocation
Type: System..::.String
Optional sign location
displaySignature
Type: System..::.Boolean
Should the signature be shown in the document?
signLLX
Type: System..::.Single
Optional lower left corner X-value of visible signature
signLLY
Type: System..::.Single
Optional lower left corner Y-value of visible signature
signRUX
Type: System..::.Single
Optional upper right corner X-value of visible signature
signRUY
Type: System..::.Single
Optional upper right corner Y-value of visible signature
signPage
Type: System..::.Int32
Optional page number to sign. Page 1 is default.
ownerPassword
Type: System..::.String
Owner password for PDF encryption.
userPassword
Type: System..::.String
User password for PDF encryption.
encryptionType
Type: bioPDF.PdfWriter..::.PdfUtil..::.EncryptionType
Type and streangth of encryption.
allowAssembly
Type: System..::.Boolean
Allow assembly.
allowCopy
Type: System..::.Boolean
Allow copy to clipboard.
allowDegradedPrinting
Type: System..::.Boolean
Allow degraded printing.
allowFillIn
Type: System..::.Boolean
Allow fill in.
allowModifyAnnotations
Type: System..::.Boolean
Allow modifying annotations.
allowModifyContents
Type: System..::.Boolean
Allow modifying contents.
allowPrinting
Type: System..::.Boolean
Allow printing.
allowScreenReaders
Type: System..::.Boolean
Allow screen readers.

See Also

PdfUtil Class
SignPdfByThumbprint Overload


WaitForFile Method

[image]

.NET Framework Class Library
PdfUtil..::.WaitForFile Method
PdfUtil Class See Also

Wait for a file to be created.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function WaitForFile ( _
    path As String, _
    timeoutMilliseconds As Integer _
) As Boolean
C#
public static bool WaitForFile(
    string path,
    int timeoutMilliseconds
)
Visual C++
public:
static bool WaitForFile(
    String^ path,
    int timeoutMilliseconds
)
JavaScript
bioPDF.PdfWriter.PdfUtil.waitForFile = function(path, timeoutMilliseconds);

Parameters

path
Type: System..::.String
Path of file to wait for.
timeoutMilliseconds
Type: System..::.Int32
Timeout in milliseconds to wait.

Return Value

True if the file is present before the timeout

See Also

PdfUtil Class


WriteIniString Method

[image]

.NET Framework Class Library
PdfUtil..::.WriteIniString Method
PdfUtil Class See Also

Write a string to an ini file.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteIniString ( _
    fileName As String, _
    sectionName As String, _
    valueName As String, _
    value As String _
)
C#
public static void WriteIniString(
    string fileName,
    string sectionName,
    string valueName,
    string value
)
Visual C++
public:
static void WriteIniString(
    String^ fileName,
    String^ sectionName,
    String^ valueName,
    String^ value
)
JavaScript
bioPDF.PdfWriter.PdfUtil.writeIniString = function(fileName, sectionName, valueName, value);

Parameters

fileName
Type: System..::.String
File name of ini file.
sectionName
Type: System..::.String
Name of section in ini file.
valueName
Type: System..::.String
Name of value in section.
value
Type: System..::.String
Value to write.

See Also

PdfUtil Class


PdfUtil Properties

[image] [image]

.NET Framework Class Library
PdfUtil Properties
PdfUtil Class See Also

The PdfUtil type exposes the following members.

Properties

Name | Description
DefaultPrinterName | Returns the default printer name for the assembly.

See Also

PdfUtil Class


DefaultPrinterName Property

[image]

.NET Framework Class Library
PdfUtil..::.DefaultPrinterName Property
PdfUtil Class See Also

Returns the default printer name for the assembly.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultPrinterName As String
C#
public static string DefaultPrinterName { get; }
Visual C++
public:
static property String^ DefaultPrinterName {
    String^ get ();
}
JavaScript
bioPDF.PdfWriter.PdfUtil.get_defaultPrinterName = function();

See Also

PdfUtil Class


PdfUtil.EncryptionType Enumeration

[image]

.NET Framework Class Library
PdfUtil..::.EncryptionType Enumeration
PdfUtil Class See Also

Encryption types when creating password protected PDF documents.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration EncryptionType
C#
public enum EncryptionType
Visual C++
public enum class EncryptionType
JavaScript
bioPDF.PdfWriter.EncryptionType = function();
bioPDF.PdfWriter.EncryptionType.createEnum('bioPDF.PdfWriter.EncryptionType', false);

Members

Member name | Description
None | No encryption.
Standard40bit | 40 bit standard encryption.
Standard128bit | 128 bit standard encryption.
AES128bit | AES 128 bit encryption.
AES256bit | AES 256 bit encryption.

See Also

bioPDF.PdfWriter Namespace


PdfUtil.PrinterSelection Enumeration

[image]

.NET Framework Class Library
PdfUtil..::.PrinterSelection Enumeration
PdfUtil Class See Also

How to selelct a printer.

Namespace: bioPDF.PdfWriter
Assembly: bioPDF.PdfWriter (in bioPDF.PdfWriter.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PrinterSelection
C#
public enum PrinterSelection
Visual C++
public enum class PrinterSelection
JavaScript
bioPDF.PdfWriter.PrinterSelection = function();
bioPDF.PdfWriter.PrinterSelection.createEnum('bioPDF.PdfWriter.PrinterSelection', false);

Members

Member name | Description
Ask | Ask the user
UseDefault | Use the default printer
Specific | Use a specific printer

See Also

bioPDF.PdfWriter Namespace